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Mobile Development with RAD Studio
• Mobile Development Landscape
• Building UI’s for Mobile with FMX

○ UI Considerations for iOS and Android
○ Frames are cool!
○ Permissions

• App Store Deployment
• Q&A
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Mobile Development with RAD Studio
• Context
• Introduction to FireMonkey (FMX)

○ Objects / Interfaces / Components
○ Styles
○ LiveBindings & Data

• Building UI’s for Mobile with FMX
○ UI Considerations for iOS and Android
○ Frames are cool!
○ LowCode Wizard

• App Store Deployment
• Q&A
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Topic - ProblemI need how many tools & languages?
Java for Android

C# for 
Windows

Swift for iOS & 
macOS
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Topic - how to solve problemThat’s Where Embarcadero Comes In . . 

● Embarcadero’s Delphi is a tool for the 
multi-device world

○ One project gives you native apps for all four 
platforms: Windows, iOS, Android, & macOS

○ Visual designer lets you design it once
○ Smart themes adapt the UI to correct platform 

behaviors
○ Create platform specific variations to tweak 

behavior on each platform if desired
○ Still with full access to platform APIs & 3rd party 

libraries
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Supports all Three Layers of Development

● Each layer builds on 
previous

● Higher layers provide 
productivity benefits

● Lower layers provide more 
control of platform

● Apps typically written with 
a combination of layers

● Delphi gives you easy 
access to all layers!
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● Delphi compiles to native code, for Intel or ARM

○ Most compilers based on LLVM infrastructure

● No runtime needed

○ No dependency on execution environment (.NET, JVM)
○ No runtime compilation, JITer, or any other layer

● Advantages

○ Fast, secure, xcopy deployment (on desktop)

No-Compromise Compiled Code
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UI Widgets: Styled vs. Native or Both
• Multi-platforms solutions offer

○ Styled (painted) controls only – often not even matching the platform
○ Native controls only – UI code changes significantly among platforms
○ “Forms” with a handful of controls

• FireMonkey
○ Extensive collection of styles controls, with platform specific styles 

(“pixel perfect”)
○ Key controls available as native controls (input controls and more)
○ Embedded complex native controls (maps, browser, etc.)
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Best in Industry: FireUI Multi-Device Designer
Shared master and specific views
Visually customize forms for different platforms and form factors
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Desktop First, Mobile Integrated
● A common scenario for business apps

● Keep the core business application on desktop

● Surface features on mobile with focused apps, notifications, etc

○ Ideally, use a shared back end

● Create companion apps via AppTethering

○ No server needed, just peer to peer to desktop app
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Entering Developer Mode
● Enter Settings

● Goto About Phone

● Software Information

● Locate Build Number

● Tap seven times

● Official instructions
https://developer.android.com/studio/debug/dev-options

● Some platforms are 
slightly different

1

2

3
3

2

1

https://developer.android.com/studio/debug/dev-options
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● After entering developer mode

● Go into Settings

● Enter Developer options

● Scroll down to USB debugging

● Enable USB debugging

● Confirm choice

1

Enable USB Debugging

1

2
2
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Set up the Environment (ADB)
When you connect your device, you’ll see a dialog similar to this on the device screen. Check the 
option to “always allow from this computer” and clock “OK”
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Lab 1 - Hello FireMonkey
● Create a FireMonkey app for Windows
● Add a TTabControl, then right click and “Add 

TTabltem”
● Include TLabel, TButton, TEdit, & TListBox on one of 

the TTabItems
● Notice TLabel & TButton have Text instead of Caption 

properties
● Notice the TTabControl has TabPosition of 

PlatformDefault
● In the OnClick event handler add the following code:

○ ListBox1.Items.Add(Edit1.Text);
● Compile and run your app on Windows

Beaker image https://pixabay.com/photo-23417/
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Lab 2 - FireMonkey Platform Services
▪ Working with your lab from earlier, add Clipboard 

support
▪ Take a look at http://embt.co/PlatformServices  
▪ Add FMX.Platform & FMX.Clipboard to your uses 

clause
▪ Interact with the clipboard via Platform Services

Clipboard image https://pixabay.com/photo-155885/

uses
  FMX.Platform, FMX.Clipboard;

procedure TFormFMXLab2.Button2Click(Sender: TObject);
var
  ClipboardService: IFMXExtendedClipboardService;
begin
  if TPlatformServices.Current.SupportsPlatformService(

IFMXExtendedClipboardService, ClipboardService) 
  then
  begin
    if ClipboardService.HasText then
      ListBox1.Items.Add(ClipboardService.GetText);
    ClipboardService.SetText('Hello FireMonkey');
  end;
end;

http://embt.co/PlatformServices
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Lab 3 - FireMonkey LiveBindings
▪ Add a TPrototypeBindSource

• Dbl Click -> Add ContactBitmapsL & 
ContactNames

▪ Add TListView
• Find the ItemAppearance.ItemAppearance 

property
 Change it from ListItem to ImageListItem

• Set 
ItemAppearanceObjects.ItemObjects.Visible to 
False

▪ Right Click ListView1 -> Bind Visually…
• Connect:

 Sync -> *
 Item.Text -> ContactName1
 Item.Bitmap -> ContactBitmatL1
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AppStore

BLOG: 
https://blogs.embarcadero.com/using-trestrequestdatasetadapter-to-update-data-via-a-restful-server-api 

Key Points
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AAB Steps
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Mobile Development 
With RAD Studio
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RAD Studio
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Getting Mobile with RAD Studio
Why RAD Studio 
for Mobile 
Development?

Market trend data clearly shows Mobile is now the dominant platform for end-user engagement, with Android the biggest platform on the market today. It is, therefore, more important than ever 
to have a mobile strategy in place as part of a complete software vision. When looking to develop a mobile application, a number of key considerations come into play, including User Experience, Data 
Security, and Total Development Costs (Covered in depth in the White Paper – RAD Studio Guide For Managers). Delphi is the only language that answers all these challenges (without compromise) by 
enabling you to build fully compiled true native applications, from a single code base for all platforms. Delphi achieves this using the same compiler as Xcode on iOS, and by compiling to the NDK on 
Android (same layer used by games developers for speed and performance), with mature run-time libraries based on modern OOP practices, allowing you to reach all platforms at the same time, 
everytime, with the lowest total cost of ownership, the fastest speed in development, and strongest security in place. 

Install & 
Initial Setup

You can download a free 30 day trial for RAD Studio Architect from 
https://www.embarcadero.com/products/rad-studio/start-for-free
Registering for the trial will send you an email with your trial key and will start the download

● The Install notes on DocWiki.Embarcadero.com give extra information. (such as minimum spec)
● Recommend you add Android and iOS as Target Platforms during installation. Along with the 

Java SDK. Alternatively you can add Target Platforms, Help, Samples, etc  by opening Tools > 
Manage Platforms in the IDE.

Quick Start 
Video

[VIDEO] IDE Setup and First Android App      https://www.youtube.com/watch?v=39IplWi0oaI
● Adding Platforms 
● Checking SDK’s
● Connecting your Device
● Deploying and debugging a Hello World App.

[VIDEO] Setup and Deploy of first iOS App       https://www.youtube.com/watch?v=Pgg4009SCEk
● Checking Platforms 
● Introduction to PAServer ready to add SDK’s
● Connecting your Device
● Deploying and debugging a Hello World App.

Videos Other popular Getting Started videos |  Mobile Weather REST Client  |  Mobile App with local data storage  |  Building & deploying your first native mobile apps for iOS and Android

Platform 
Requirements

Android : The same machine (or VM) your IDE is installed in will do (Windows 10). You also need to 
ensure the JDK and SDK are installed for Android. (check Tools > Manage Platforms > Extras). if you 
manually install the SDKs, please check pathings in Tools > Options > Deployment > SDK Manager

iOS : To deploy onto iOS hardware, you need to be enrolled in the Apple Developer Program and 
have access to Apple hardware (legal thing in the Apple EULAs for app signing). RAD Studio uses 
PAServer as the bridge to the host mac to enable the device to run and debug from the IDE.

Low Code 
Wizard 

● Low code Wizard : Under Tools > GetIt Package Manager Install the “FireMonkey App Low Code 
Wizard”. Then File > New > Other > Delphi > Multi-Device > FireMonkey Template App. 

● This wizard generates a outlined project with frames, unit test, and best practice MVC examples.

● Alternatively use File > New > Multi-device Application - to create a blank project. 
● Top Tip - As you see from the Low Code Wizard, Frames can make mobile app development a lot 

easier. Check out TFrameStand in GetIt

Frameworks and 
Libraries

● FireMonkey (FMX) is the UI framework used for visually designing stunning cross platform apps.
● FMX uniquely enables developers to choose native or styled controls for ultimate platform fidelity.
● Control styles default to the platform look and feel for the best, expected, user experience, but can 

also be overridden for a truly customized design by using a single “StyleBook” component..  
● FMX supports styles & [Video] 60+ no code shader effects. (such as Glow Effects to highlight 

required fields to end users) 

● Core multi-platform runtime library include Database access library (FireDAC) and core System 
libraries e.g. Generics, Parallel Programming Library, JSON, IOUtils, Regular Expressions 
NetEncoding and more.  

● [Video] Language Features and RTL libraries introduction - http://bit.ly/WelcomeToDelphi 
● Checkout  the Samples folder for examples of UI Controls, Sensors, and Frameworks in action.

Prototype 
Faster!

● To support differences in platform standards (e.g. Tabs at Top on Android and bottom on iOS) FMX 
controls includes options for setting values to “Platform Default”. 

● On Device Live Preview with FireUI - RAD Studio enables you to view your form, with prototype data 
as you build the UI, and how it looks differently on different platforms. Checkout FireUI

● InterBase + FireDAC give you have a highly powerful cross platform database that works across 
the development cycle on Windows, Linux, macOS, iOS & Android.

● InterBase ToGo run time license is Included in Enterprise and Architect editions, and includes the 
IoT Award winning Change Views, for tracking field level changes in the data layer, enabling 
developers to build apps faster with local data storage they can sync remotely when back online.

Need Advice? Embarcadero pre-sales engineers are available to discuss your project requirements and help point you in the right direction. Ask your local sales rep for an appointment..

https://blogs.embarcadero.com/key-target-platforms-update/
https://lp.embarcadero.com/RAD-Studio-Guide-For-Managers
https://www.embarcadero.com/products/rad-studio/start-for-free
http://docwiki.embarcadero.com/RADStudio/en/Installation_Notes
https://www.youtube.com/watch?v=39IplWi0oaI&list=PL4APVmQs5tUpdh24gnyRTFHVpkKwNht0K&index=1
https://www.youtube.com/watch?v=39IplWi0oaI
https://www.youtube.com/watch?v=Pgg4009SCEk&list=PL4APVmQs5tUpdh24gnyRTFHVpkKwNht0K&index=2
https://www.youtube.com/watch?v=Pgg4009SCEk
https://www.youtube.com/watch?v=bjSyafXYdoI&list=PLwUPJvR9mZHja62Q4b_n4gVb0MjsUzanc&index=8
https://www.youtube.com/watch?v=--HfSCnp24o&list=PLwUPJvR9mZHja62Q4b_n4gVb0MjsUzanc&index=12
https://www.youtube.com/watch?v=HbkGM42YPrk
http://docwiki.embarcadero.com/RADStudio/en/Android_Mobile_Application_Development
http://docwiki.embarcadero.com/RADStudio/en/IOS_Mobile_Application_Development
https://www.youtube.com/watch?v=Z6_ZvnCmFCw
https://www.youtube.com/watch?v=OMpiR62CNxs
http://docwiki.embarcadero.com/RADStudio/en/FireDAC
http://docwiki.embarcadero.com/RADStudio/en/Generics_Index
http://docwiki.embarcadero.com/RADStudio/en/Using_the_Parallel_Programming_Library
http://docwiki.embarcadero.com/Sydney/en/JSON
http://docwiki.embarcadero.com/Libraries/en/System.IOUtils
http://docwiki.embarcadero.com/RADStudio/en/Regular_Expressions
http://docwiki.embarcadero.com/Libraries/en/System.NetEncoding
https://www.youtube.com/watch?v=k6wLx53VSGU&list=PLwUPJvR9mZHja62Q4b_n4gVb0MjsUzanc&index=6
http://docwiki.embarcadero.com/RADStudio/en/FireUI_Live_Preview
https://www.interbase.com
https://www.embarcadero.com/company/contact-sales
https://www.youtube.com/watch?v=39IplWi0oaI
https://www.youtube.com/watch?v=Pgg4009SCEk

